View Issue Details

IDProjectCategoryView StatusLast Update
0026921mantisbtbugtrackerpublic2020-05-03 04:34
Reporterpolzin Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.23.0 
Target Version2.24.1Fixed in Version2.24.1 
Summary0026921: View Issue page does not show "Product Build" (wrong key names in code)
Description

"Product Build" are only shown on bug_report and bug_update, but not on view. (if $g_enable_product_build = ON)

The reason are wrong key names in bug_view_inc.php

The right field for Product Build is 'build' not 'product_build'.

See attached patch.

Additional Information
@@ -480,7 +480,7 @@ if( ( $t_flags['profiles_platform_show'] && isset( $t_issue['platform'] ) && !is
 #

 if( ( $t_flags['versions_product_version_show'] && isset( $t_issue['version'] ) ) ||
-    ( $t_flags['versions_product_build_show'] && isset( $t_issue['product_build'] ) ) ) {
+    ( $t_flags['versions_product_build_show'] && isset( $t_issue['build'] ) ) ) {
        $t_spacer = 2;

        echo '<tr>';
@@ -494,9 +494,9 @@ if( ( $t_flags['versions_product_version_show'] && isset( $t_issue['version'] )
        }

        # Product Build
-       if( $t_flags['versions_product_build_show'] && isset( $t_issue['product_build'] ) ) {
+       if( $t_flags['versions_product_build_show'] && isset( $t_issue['build'] ) ) {
                echo '<th class="bug-product-build category">', lang_get( 'product_build' ), '</th>';
-               echo '<td class="bug-product-build">', string_display_line( $t_issue['product_build'] ), '</td>';
+               echo '<td class="bug-product-build">', string_display_line( $t_issue['build'] ), '</td>';
        } else {
                $t_spacer += 2;
        }
TagsNo tags attached.

Relationships

related to 0026838 closedatrol OS build field not filled in viewing mode 
related to 0025902 closedvboctor Implement IssueViewPageCommand to separate logic from rendering of issue view page 

Activities

polzin

polzin

2020-04-28 04:34

reporter   ~0063923

@atrol This is a related bug to 0026838

polzin

polzin

2020-04-28 04:43

reporter   ~0063925

I am sorry, the patch file in additional information got corrupted with the markup and I cannot change it.

atrol

atrol

2020-04-29 15:03

developer   ~0063930

Regression introduced in 2.23.0

atrol

atrol

2020-04-29 16:07

developer   ~0063932

Last edited: 2020-04-29 16:10

View 3 revisions

The issue is similar to what we had with os_version vs. os_build

The name of the field in settings like $g_bug_view_page_fields is product_build
The name of the field on Manage Columns pages is build

polzin

polzin

2020-04-29 17:04

reporter   ~0063935

Same for product_version and version. As this field is more important thant the others, it might be sensible to check, if harmoizing breaks existing configurations or filters.

atrol

atrol

2020-05-01 15:40

developer   ~0063943

PR https://github.com/mantisbt/mantisbt/pull/1665

atrol

atrol

2020-05-01 15:59

developer   ~0063944

Last edited: 2020-05-01 22:30

View 2 revisions

it might be sensible to check, if harmoizing breaks existing configurations or filters.

@polzin, right harmonizing would break.
Not sure you noticed that I introduced a check in admin checks when harmonizing os_version and os_build.
Admins are told to run admin/check/index.php after upgrade, so they will get a warning.

Related Changesets

MantisBT: master-2.24 5ba7cdf2

2020-05-02 19:44:36

atrol


Committer: community Details Diff
Fix Product Build display on View Issue page

Regression introduced in 2.23.0

Fixes 0026921
Affected Issues
0026921
mod - bug_view_inc.php Diff File

Issue History

Date Modified Username Field Change
2020-04-28 04:34 polzin New Issue
2020-04-28 04:34 polzin Note Added: 0063923
2020-04-28 04:43 polzin Note Added: 0063925
2020-04-29 14:35 atrol Additional Information Updated View Revisions
2020-04-29 14:35 atrol Additional Information Updated View Revisions
2020-04-29 15:00 atrol Relationship added related to 0026838
2020-04-29 15:01 atrol Product Version 2.24.0 => 2.23.0
2020-04-29 15:02 atrol Relationship added related to 0025902
2020-04-29 15:03 atrol Status new => confirmed
2020-04-29 15:03 atrol Note Added: 0063930
2020-04-29 16:07 atrol Note Added: 0063932
2020-04-29 16:07 atrol Note Edited: 0063932 View Revisions
2020-04-29 16:10 atrol Note Edited: 0063932 View Revisions
2020-04-29 17:04 polzin Note Added: 0063935
2020-05-01 15:39 atrol Assigned To => atrol
2020-05-01 15:39 atrol Status confirmed => assigned
2020-05-01 15:40 atrol Target Version => 2.24.1
2020-05-01 15:40 atrol Note Added: 0063943
2020-05-01 15:59 atrol Note Added: 0063944
2020-05-01 22:30 vboctor Note Edited: 0063944 View Revisions
2020-05-02 19:44 community Changeset attached => MantisBT master-2.24 5ba7cdf2
2020-05-02 19:44 atrol Status assigned => resolved
2020-05-02 19:44 atrol Resolution open => fixed
2020-05-02 19:44 atrol Fixed in Version => 2.24.1
2020-05-03 04:34 vboctor Status resolved => closed