View Issue Details

IDProjectCategoryView StatusLast Update
0027362mantisbtinstallationpublic2020-10-08 19:50
Reportersam888 Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.24.2 
Fixed in Version2.25.0 
Summary0027362: Sourceforge [admin/test_langs.php] File missing from installation packages ( mantisbt-2.24.3.zip & mantisbt-2.24.3.tar.gz)
Description

The release files on Github contain [admin/test_langs.php] .

Steps To Reproduce

Un-archive the release files and look in the admin directory for test_langs.php

Additional Information

https://github.com/mantisbt/mantisbt/tree/master/admin

https://sourceforge.net/projects/mantisbt/files/mantis-stable/2.24.3/

https://github.com/mantisbt/mantisbt/releases/tag/release-2.24.3

Question: Attemping to install from the Github release files gives the following error (but works with the sourceforge release files!)

[27-Sep-2020 20:56:33 UTC] PHP Fatal error: require_once(): Failed opening required '/home/hostname/public_html/mantisbt/vendor/autoload.php' (include_path='.:/opt/cpanel/ea-php72/root/usr/share/pear') in /home/hostname/public_html/mantis/core.php on line 91

TagsNo tags attached.

Relationships

related to 0027057 closeddregad PHP Fatal error: Uncaught Error: Call to undefined method ComposerAutoloaderInitfa60a1d30e82198ab309dba1a3049801 
related to 0026903 resolvedvboctor Move release scripts to main repository 
related to 0027384 resolveddregad Upgrade release build scripts to Python3 
related to 0027383 assigneddregad Move 'test_langs.php' script to admin checks 

Activities

sam888

sam888

2020-09-27 18:01

reporter   ~0064502

Question: Attemping to install from the Github release files gives the following error (but works with the sourceforge release files!)

Worked out my question 0027057:0064124 <i>If you use the "official" install package from SourceForge, then you don't need to run Composer, the libraries are bundled in the tarball. Running Composer yourself is only needed if you get the MantisBT source from GitHub.</i>

Suggestion maybe add a message about to the release on Github ( you can edit each release we do it for the Gramps project).

atrol

atrol

2020-09-28 16:23

developer   ~0064505

Last edited: 2020-09-28 16:23

View 2 revisions

Our problems is that we can't tag without creating a release on GitHub, see this discussion.

sam888

sam888

2020-09-28 16:50

reporter   ~0064507

@atrol ? You answered my secondary question. What about the primary issue I raise that you just resolved how are the files for sourceforge generated because files are missing?

atrol

atrol

2020-09-28 17:02

developer   ~0064508

@sam888 you are right.
The issue started in 2.24.2

atrol

atrol

2020-09-28 17:05

developer   ~0064509

Assigning to @dregad who prepared the 2.24.2 and 2.24.3 releases.

dregad

dregad

2020-09-29 10:07

developer   ~0064512

Last edited: 2020-09-29 12:29

View 2 revisions

Regarding the releases page on GitHub I created a dummy release to inform user not to use these zip/tarballs.
Unfortunately, the price we have to pay for this, is having to keep a "dummy" tag in the repository, and we'll probably have to bump the tag after every release to ensure it remains on top, too... Hopefully GitHub will address this silly "feature" of creating these source tarballs, eventually.

I need to look into what happened with the release build script, that caused some files to be missing.

dregad

dregad

2020-09-29 12:17

developer   ~0064513

Last edited: 2020-09-29 12:17

View 2 revisions

So the absence of test_langs.php in the tarballs is due to the release build script specifically excluding it.

This was introduced as part of moving the release scripts into the main repo (see 0026903):
https://github.com/mantisbt/mantisbt/commit/14ae1c8a8c49eb1caede6e3b51e60254747e44ff#diff-39c328898abb8582de1920f694c51353R28.

I have no idea why @vboctor decided to exclude that file and maybe he'll care to comment, but considering that it is still referenced in the Admin pages' GUI, I guess that the change may have been unintentional. Or if it was done on purpose, then it should have been properly and fully removed from the code base.

dregad

dregad

2020-09-29 12:23

developer   ~0064514

Suggestion maybe add a message about to the release on Github ( you can edit each release we do it for the Gramps project).

So this is how it looks now:

image.png (9,167 bytes)   
image.png (9,167 bytes)   
image-2.png (26,147 bytes)   
image-2.png (26,147 bytes)   
vboctor

vboctor

2020-10-04 21:36

manager   ~0064520

@dregad I probably removed it since it is a dev script like the test cases, composer files, etc. However, I missed that it had a link from the admin page. I would suggest removing the link to it from admin experience.

atrol

atrol

2020-10-05 15:21

developer   ~0064524

The script can be useful for admins to check language files of 3rd party plugins.

dregad

dregad

2020-10-06 03:46

developer   ~0064526

The script can be useful for admins to check language files of 3rd party plugins.

I agree. I propose to revert the exclusion from the build script, bundle 2.24.2 + 2.24.3 again, and republish the tarballs to SourceForge.

The test_langs.php script is very dated. Its output is crap, and it contains obsolete code for PHP 4 compatibility (!). Maybe we can refactor it into a new section of our admin checks process, what do you think ?

dregad

dregad

2020-10-08 12:08

developer   ~0064533

OK, so without further feedback I'll proceed with reverting and rebuild the tarballs.

I have opened 0027383 to track refactoring of test_langs.php.

dregad

dregad

2020-10-08 19:50

developer   ~0064535

Updated tarballs for 2.24.2 and 2.24.3 have been uploaded to Sourceforge.

Related Changesets

MantisBT: master dd12aae7

2020-10-08 18:26:07

dregad

Details Diff
Do not exclude 'test_langs.php' from builds

Fixes 0027362
Affected Issues
0027362
mod - build/buildrelease.py Diff File

Issue History

Date Modified Username Field Change
2020-09-27 17:55 sam888 New Issue
2020-09-27 18:01 sam888 Note Added: 0064502
2020-09-28 16:13 atrol Relationship added related to 0027057
2020-09-28 16:23 atrol Note Added: 0064505
2020-09-28 16:23 atrol Note Edited: 0064505 View Revisions
2020-09-28 16:23 atrol Relationship replaced duplicate of 0027057
2020-09-28 16:24 atrol Assigned To => atrol
2020-09-28 16:24 atrol Status new => resolved
2020-09-28 16:24 atrol Resolution open => duplicate
2020-09-28 16:50 sam888 Note Added: 0064507
2020-09-28 16:51 sam888 Status resolved => feedback
2020-09-28 16:51 sam888 Resolution duplicate => reopened
2020-09-28 17:02 atrol Status feedback => confirmed
2020-09-28 17:02 atrol Product Version 2.24.3 => 2.24.2
2020-09-28 17:02 atrol Note Added: 0064508
2020-09-28 17:02 atrol Relationship replaced related to 0027057
2020-09-28 17:05 atrol Note Added: 0064509
2020-09-28 17:05 atrol Assigned To atrol => dregad
2020-09-29 10:07 dregad Note Added: 0064512
2020-09-29 12:17 dregad Note Added: 0064513
2020-09-29 12:17 dregad Note Edited: 0064513 View Revisions
2020-09-29 12:17 dregad Relationship added related to 0026903
2020-09-29 12:23 dregad Note Added: 0064514
2020-09-29 12:23 dregad File Added: image.png
2020-09-29 12:23 dregad File Added: image-2.png
2020-09-29 12:29 dregad Note Edited: 0064512 View Revisions
2020-10-04 21:36 vboctor Note Added: 0064520
2020-10-05 15:21 atrol Note Added: 0064524
2020-10-06 03:46 dregad Note Added: 0064526
2020-10-08 12:07 dregad Issue cloned: 0027383
2020-10-08 12:07 dregad Relationship added related to 0027383
2020-10-08 12:08 dregad Status confirmed => assigned
2020-10-08 12:08 dregad Note Added: 0064533
2020-10-08 19:46 dregad Changeset attached => MantisBT master dd12aae7
2020-10-08 19:46 dregad Status assigned => resolved
2020-10-08 19:46 dregad Resolution reopened => fixed
2020-10-08 19:46 dregad Fixed in Version => 2.25.0
2020-10-08 19:49 dregad Relationship added related to 0027384
2020-10-08 19:50 dregad Note Added: 0064535