View Issue Details

IDProjectCategoryView StatusLast Update
0027575mantisbtcode cleanuppublic2020-11-22 06:10
Reporterdregad Assigned Todregad  
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027575: Remove obsolete 'posted' form param when reporting new issue
Description

This parameter was previously used to detect oversize file attachments when reporting issues (see 0007118).

With the introduction of dropzone which validates attachment size prior to form submission, it was no longer necessary, and the validation code was removed with the introduction of IssueAddCommand (0023998).

The parameter should be removed from bug_report_page.php.

TagsNo tags attached.

Relationships

related to 0007118 closedgrangeway Report Issue: attaching an oversized file raises wrong error message in bug_report.php/gpc_get (gpc_api.php) 
related to 0023998 closedvboctor Implement IssueAddCommand and use it from SOAP, REST and Web UI 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master ed6571e2

2020-11-22 04:56:27

dregad

Details Diff
Remove obsolete form param in bug_report_page.php

'posted' Parameter is not necessary anymore since the implementation of
dropzone, and was removed from bug_report.php when IssueAddCommand
was introduced.

Fixes 0027575
Affected Issues
0027575
mod - bug_report_page.php Diff File

Issue History

Date Modified Username Field Change
2020-11-22 04:54 dregad New Issue
2020-11-22 04:54 dregad Status new => assigned
2020-11-22 04:54 dregad Assigned To => dregad
2020-11-22 05:13 dregad Relationship added related to 0007118
2020-11-22 05:13 dregad Relationship added related to 0023998
2020-11-22 06:10 dregad Changeset attached => MantisBT master ed6571e2
2020-11-22 06:10 dregad Status assigned => resolved
2020-11-22 06:10 dregad Resolution open => fixed
2020-11-22 06:10 dregad Fixed in Version => 2.25.0