View Issue Details

IDProjectCategoryView StatusLast Update
0027830mantisbtdb postgresqlpublic2021-03-07 18:28
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027830: PHP 8.0 PostgreSQL builds fail due to deprecated pg_fieldsize() function
Description

PHP 8.0 deprecated several pgsql function aliases [1] cause TravisCI builds to fail with 65 occurences of the error below

SoapFault: Error Type: ,
Error Description: Function pg_fieldsize() is deprecated

/home/travis/build/dregad/mantisbt/tests/soap/IssueAddTest.php:62 
Additional Information

This is a problem with the ADOdb library, and has been reported upstream - see https://github.com/ADOdb/ADOdb/issues/667

Tagsadodb, PHP 8, postgresql, TravisCI

Relationships

related to 0027829 closeddregad TravisCI: add PHP 8.0 to tests, and switch to bionic build environment 
parent of 0026837 closeddregad Update ADOdb to 5.20.20 

Activities

dregad

dregad

2021-01-01 20:55

developer   ~0064911

Until the problem is fixed in ADOdb, we allow the PHP 8 Travis builds for pgsql to fail (see MantisBT master f16906f9 ).

dregad

dregad

2021-02-07 09:11

developer   ~0065074

Problem is fixed in ADOdb 5.20.20, released 01-Feb-2021 - https://github.com/ADOdb/ADOdb/releases/tag/v5.20.20

Related Changesets

MantisBT: master f16906f9

2021-01-01 19:36:18

dregad

Details Diff
TravisCI: enable PHP 8.0 builds

Allow pgsql to fail due to issue 0027830.

Fixes 0027829
Affected Issues
0027829, 0027830
mod - .travis.yml Diff File

MantisBT: master c9fc9a84

2021-02-02 00:25:51

dependabot-preview[bot]


Committer: dregad Details Diff
Bump adodb/adodb-php from 5.20.19 to 5.20.20

Bumps [adodb/adodb-php](https://github.com/ADOdb/ADOdb) from 5.20.19 to 5.20.20.
- [Release notes](https://github.com/ADOdb/ADOdb/releases)
- [Changelog](https://github.com/ADOdb/ADOdb/blob/master/docs/changelog.md)
- [Commits](https://github.com/ADOdb/ADOdb/compare/v5.20.19...v5.20.20)

Signed-off-by: dependabot-preview[bot] <support@dependabot.com>

Fixes 0026837, 0027830, PR https://github.com/mantisbt/mantisbt/pull/1735
Affected Issues
0026837, 0027830
mod - composer.lock Diff File

MantisBT: master 657121ff

2021-02-14 18:08:23

dregad

Details Diff
TravisCI PHP 8.0 builds on pgsql required again

The compatibility problem described in issue 0027830 has been fixed in
ADOdb 5.20.20, so the TravisCI builds for PHP 8.0 on pgsql are no longer
allowed to fail.

This is a partial revert of f16906f9b5ac975b5b34889a354fd8c7f74e4a8d.
Affected Issues
0027830
mod - .travis.yml Diff File